Buddy Punch App - Outage
Incident Report for Buddy Punch
Resolved
This incident has been resolved.
Posted about 2 years ago. Nov 10, 2016 - 22:58 UTC
Monitoring
Issue is resolving
Posted about 2 years ago. Nov 10, 2016 - 22:55 UTC
Investigating
We are investigating with your hosting provider.
Posted about 2 years ago. Nov 10, 2016 - 22:33 UTC