BuddyPunch.com experiencing downtime
Incident Report for Buddy Punch
Resolved
BuddyPunch.com has fully recovered.
Posted about 2 years ago. Nov 01, 2016 - 03:34 UTC
Identified
BuddyPunch.com company website and blog are experiencing down time. The application at https://app.buddypunch.com is unaffected.
Posted about 2 years ago. Oct 31, 2016 - 15:27 UTC