Delayed Payments
Incident Report for Buddy Punch
Resolved
We have confirmed our ACH file has been received. All Direct Deposits dated for today will be posted by the bank and funds will be posted at 5pm local time. While this should resolve the issue and remit payments to affected employees, we will continue to monitor to confirm that the payments successfully land in accounts.

We sincerely apologize for this delay.
Posted Jan 27, 2023 - 15:54 UTC
Identified
We have isolated the issue to one of our banking providers and are actively investigating root cause and resolution paths with that provider. We are simultaneously exploring other means to send employee payments today.

We remain confident that employee payments will land today. We will send an updated status within the next hour or if we have meaningful updates to share in the interim.
Posted Jan 27, 2023 - 15:23 UTC