Time Entries (Duration) on Web
Incident Report for Buddy Punch
Resolved
This issue is now resolved. You will be able to add time entries as expected.
Posted 7 months ago. Oct 29, 2018 - 14:13 UTC
Investigating
We are aware of an issue with Time Entries (duration) when accessing them via a browser. We are working to resolve this issue. In the meantime we would recommend adding time entries from the Mobile Apps, they are working as expected.
Posted 7 months ago. Oct 29, 2018 - 13:58 UTC
This incident affected: Web Application (app.buddypunch.com).