Delayed Employee / Contractor Payments
Incident Report for Buddy Punch
Resolved
This incident has been resolved.
Posted Mar 11, 2023 - 02:30 UTC
Update
Great news. All remaining payments that were not sent earlier have now been fully released to the Federal Reserve. These payments will go out in the 4:45pm ET Same Day ACH window.

As a reminder, funds will settle with the receiving bank by 6pm local time; note that while funds are often made available immediately, it is up to the discretion of the bank itself on when they make those funds available to the employee / contractor in their bank account. By law it is Midnight local time, but timing varies bank by bank.

In the meantime, we will continue to actively monitor the status of these payments to ensure smooth delivery.

Thank you for your patience and support.
Posted Mar 10, 2023 - 21:30 UTC
Update
We are continuing to work closely with our banking partner to ensure payments go out today.

We have identified all employees & contractors who have yet to be paid. We have now provided all required information to their team to create and submit the ACH file required to send payments, and are actively working with them to ensure that file is submitted on time. We jointly expect to meet the 4:45pm ET Same Day ACH window.

Funds will settle with the receiving bank by 6pm local time; note that while funds are often made available immediately, it is up to the discretion of the bank itself on when they make those funds available to the employee / contractor in their bank account. By law it is Midnight local time, but timing varies bank by bank.

We appreciate your continued understanding and patience. We will follow up with more details no later than 5:00pm ET.
Posted Mar 10, 2023 - 20:15 UTC
Update
We have continued to receive some positive reports that employees & contractors have received their funds.

We remain committed to paying all employees & contractors today and will send out any additional payments, if needed, by latest the final Same Day ACH submission window at 4:45pm ET.

We appreciate your continued understanding and patience.

We will follow up between 2:45-3:30pm ET with an update.
Posted Mar 10, 2023 - 18:57 UTC
Monitoring
Due to an issue with our banking provider, employee & contractor funds for payrolls that were meant to be paid today are delayed.

We are confident that payments for your employees & contractors will land today. We will follow up with more details around specific payment timing as we receive confirmation.

We apologize for this inconvenience. Nothing is more important to our service than processing timely and accurate payments for you. We will work with our banking provider to identify the issue and resolve it on a go forward basis.
Posted Mar 10, 2023 - 13:57 UTC