Connection issue
Incident Report for Buddy Punch
Resolved
The issue has been resolved.
Posted 6 months ago. Dec 10, 2018 - 19:24 UTC
Identified
We are aware of an issue with connections to the website and app. We are working to resolve it as quickly as possible.
Posted 6 months ago. Dec 10, 2018 - 18:59 UTC
This incident affected: Web Application (app.buddypunch.com) and API.