Buddy Punch host Microsoft Azure is having an issue. We are aware and investigating

Incident Report for Buddy Punch

Resolved

This incident has been resolved.
Posted Apr 01, 2021 - 22:45 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2021 - 22:32 UTC

Investigating

We are currently investigating this issue.
Posted Apr 01, 2021 - 21:51 UTC
This incident affected: Web Application (app.buddypunch.com) and API.