Buddy Punch is experiencing connectivity issues
Incident Report for Buddy Punch
Resolved
This incident has been resolved.
Posted 24 days ago. May 03, 2019 - 00:07 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 24 days ago. May 02, 2019 - 21:34 UTC
Investigating
We are currently investigating the issue.
Posted 24 days ago. May 02, 2019 - 21:07 UTC
This incident affected: Web Application (app.buddypunch.com) and API.