Elevated Errors
Incident Report for Buddy Punch
Resolved
Issues have been resolved at hosting provider.
Posted almost 2 years ago. Sep 15, 2016 - 14:58 UTC
Identified
We're experiencing an elevated level of errors. This appears to be caused by an issue at our hosting provider. We will update as soon as possible.
Posted almost 2 years ago. Sep 15, 2016 - 12:22 UTC