Investigating errors on Buddy Punch web application
Incident Report for Buddy Punch
Resolved
Issues logging in appear to be resolved. We are continuing to work with our cloud hosting provider on the issue.
Posted over 1 year ago. Sep 07, 2016 - 21:28 UTC
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Sep 07, 2016 - 20:31 UTC