Degraded Performance
Incident Report for Buddy Punch
Resolved
The issue has been resolved
Posted 11 months ago. Nov 06, 2017 - 21:33 UTC
Monitoring
The website and mobile apps are starting to respond as normal. We will continue to monitor the situation.
Posted 11 months ago. Nov 06, 2017 - 21:12 UTC
Identified
An issue with our cloud hosting provider is causing some degraded performance. The mobile apps appear to be working better than the website at this time.
Posted 11 months ago. Nov 06, 2017 - 20:51 UTC
Investigating
We are investigating some failed logins, time outs and slow response times.
Posted 11 months ago. Nov 06, 2017 - 20:32 UTC