Buddy Punch slow loading and errors
Incident Report for Buddy Punch
Resolved
The performance issue has been resolved
Posted about 1 year ago. Aug 18, 2017 - 03:39 UTC
Investigating
We are investigating the slow performance of Buddy Punch
Posted about 1 year ago. Aug 18, 2017 - 01:09 UTC