Buddy Punch application is down
Incident Report for Buddy Punch
Resolved
The issue has been resolved.
Posted almost 2 years ago. Nov 29, 2016 - 22:14 UTC
Monitoring
The issue appears to be resolving. We will continue to monitor
Posted almost 2 years ago. Nov 29, 2016 - 21:52 UTC
Investigating
We are working with Microsoft to resolve this issue.
Posted almost 2 years ago. Nov 29, 2016 - 21:48 UTC