Service Interuption
Incident Report for Buddy Punch
Resolved
All issues have been resolved
Posted almost 2 years ago. Jul 18, 2016 - 20:59 UTC
Monitoring
Buddy Punch is back up and running. We will continue to monitor the performance.
Posted almost 2 years ago. Jul 18, 2016 - 20:08 UTC
Investigating
We are investigating slow performance and customers not able to access Buddy Punch
Posted almost 2 years ago. Jul 18, 2016 - 19:59 UTC