Access Issues
Incident Report for Buddy Punch
Resolved
The technical issues appear to be resolved.
Posted almost 2 years ago. Aug 24, 2016 - 19:02 UTC
Monitoring
We are monitoring the situation as some customers are unable to access Buddy Punch.
Posted almost 2 years ago. Aug 24, 2016 - 18:24 UTC