System performance issue
Incident Report for Buddy Punch
Resolved
Performance issue has been resolved. You should now be able to login normally.
Posted 3 months ago. Mar 01, 2018 - 17:23 UTC
Investigating
We are currently investigating a performance issue. You may have trouble accessing the site while we are investigating.
Posted 3 months ago. Mar 01, 2018 - 17:16 UTC